PT Calendar

From ADF Docs
Jump to: navigation, search

About the Calendar App

The Calendar application is built using the Application Development Framework (ADF).


Overview

The Calendar application for robust handling and display of events. Calendars can be displayed by day, week and month in both list and grid formats. The events that show in the calendars can be determined by Organization, Category, Approval Status and many more parameters. This fine level of control makes it ideal for having internal and external facing calendars for your organization.

Requirements

ADF Library components that are required for the Calendar application:

  • CEData_1_1
  • CSData_1_1
  • Data_1_1
  • Date_1_1
  • Forms_1_1
  • Scripts_1_1
  • UI_1_0
  • CCAPI

App v3.0 and higher also requires:

  • CSContent_1_0
  • Utils_1_1

The ADF must be configured correctly on your site for Calendar App. Please check the Install and Upgrade guides for the minimum required ADF version.

The Site Configuration (ADF.cfc) wiki page has instructions for configuration.


Pre-installation Considerations

The Application Development Framework (ADF) must be setup and configured on the server for the site that will be implementing the Social Media application. For detailed instructions follow the ADF Overview wiki page for Site Configurations.

This installation guide assumes that you have no Custom Elements and/or Metadata Forms with the names above. Before the install, remove any Custom Elements/Metadata Forms with the names listed in the "Contents" section above. (If you do not remove existing elements with these names, you may have difficulties during the installation.)

Installation Guides

Current ADF 2.x Release Version:

Previous ADF 2.x Versions:

IMPORTANT: v4.x of this application requires ADF 2.0 or greater (and CommonSpot 10 or greater)

Current ADF 1.8.x Release Version:

IMPORTANT: v3.1 of this application requires the ADF 1.7 up to ADF 1.8.x


IMPORTANT: v3.0 of this application requires ADF 1.6 up to ADF 1.8.x

Calender 2.x Versions:


IMPORTANT: v2.x of this application requires ADF 1.5 up to ADF 1.8.x

Known Issues/Bugs

Found a bug, view the PT Calendar Issues page. Your issue not on the list? Then post it so the issue can be addressed.